华为数通 IPv6过渡技术:静态IPv6手动隧道、GRE手动隧道,IPv6自动隧道6to4、ISATAP

华为数通 IPv6过渡技术:静态IPv6手动隧道、GRE手动隧道,IPv6自动隧道6to4、ISATAP
手动和自动的区别就是在于目的地址是手动配置还是自动配置,自动配置就是多目的地址通过报文自动判断出,不需要自己手动配置。
需要ipv6隧道的作用是在于ipv4转ipv6时间太长,为了过渡才出现的过渡技术,所以是为了共存而存在的

手动隧道

手动配置隧道终点的ipv4地址

GRE封装带GRE报文,GRE携带的协议更多使用场景更广,MTU是1476,手动ipv6 over ipv4隧道的MTU是1480,更建议使用gre

MTU的值是因为ipv6中携带了ipv4报文,ipv4报文占用20,gre报头是4,所以gre隧道MTU是1476。默认就是这个数值如果隧道建立不成功需要检查。

华为数通 IPv6过渡技术:静态IPv6手动隧道、GRE手动隧道,IPv6自动隧道6to4、ISATAP
AR1:
[R1]interface GigabitEthernet0/0/0
 ip address 12.0.0.1 255.255.255.0 
#
[R1]interface GigabitEthernet0/0/1
 ipv6 enable 
 ipv6 address 1::1/64 
[R1]interface LoopBack0
 ip address 1.1.1.1 255.255.255.255 
#
[R1]interface Tunnel0/0/0
 ipv6 enable 
 ipv6 address 13::1/64        # 同理GRE不检查同网段,两端可以不同网段
 tunnel-protocol gre          # 建议GRE不建议ipv6 over ipv4,两者除了接口模式命令不一样之外其他命令一样
 source 1.1.1.1      # 隧道源可以指定接口,在于没有固定公网ipv4的情况下建立隧道
 destination 3.3.3.3
#
[R1]ip route-static 0.0.0.0 0.0.0.0 12.0.0.2
#
[R1]ipv6 route-static 3:: 64 Tunnel0/0/0
AR3:
[R3]interface GigabitEthernet0/0/0
 ip address 23.0.0.3 255.255.255.0 
#
[R3]interface GigabitEthernet0/0/1
 ipv6 enable 
 ipv6 address 3::1/64
[R3]interface LoopBack0
 ip address 3.3.3.3 255.255.255.255 
#
[R3]interface Tunnel0/0/0
 ipv6 enable 
 ipv6 address 13::3/64 
 tunnel-protocol gre
 source 3.3.3.3
 destination 1.1.1.1
#
[R3]ip route-static 0.0.0.0 0.0.0.0 23.0.0.2
#
[R3]ipv6 route-static 1:: 64 Tunnel0/0/0 
华为数通 IPv6过渡技术:静态IPv6手动隧道、GRE手动隧道,IPv6自动隧道6to4、ISATAP
链路本地地址华为默认前96位FE80::,后32位取至隧道源地址
华为数通 IPv6过渡技术:静态IPv6手动隧道、GRE手动隧道,IPv6自动隧道6to4、ISATAP
华为数通 IPv6过渡技术:静态IPv6手动隧道、GRE手动隧道,IPv6自动隧道6to4、ISATAP
抓包看出pc1往pc2报文封装依次是ipv4、gre、ipv6通信报文

作者:Zleoco,如若转载,请注明出处:https://www.zleoco.com/?p=2122

发表回复

您的电子邮箱地址不会被公开。