华为数通 E-trunk

E-trunk

  • eth-trunk无法实现跨设备链路聚合,只是一种单板级的可靠性方案,E-trunk是为了解决eth-trunk的问题。实现跨设备链路聚合的机制,基于LACP进行了扩展
  • 实现多设备间的链路聚合,从而将链路可靠性从单板机提高到设备级

应用案例

华为数通 E-trunk
SW1创建g0/0/1 to 0/0/4的eth-trunk逻辑接口1(可以和sw2、sw3的逻辑接口id不同,这里只是为了方便所以使用1)
SW2和SW3的eth-trunk ID必须一致,所以都是1
S1:
[S1]sys S1
[S1]int Eth-Trunk 1
     mode lacp-static     # 使用lacp建立接口
     trunkport GigabitEthernet 0/0/1 to 0/0/4
S2:
[S2]sys S2
[S2]lacp e-trunk priority 100     # 设置e-trunk的LACP优先级
[S2]lacp e-trunk system-id 0000-1111-2222     # 设置e-trunk的LACP系统ID,LACP优先级和LACP系统ID主备设备必须设置一样
[S2]interface Vlanif1
     ip address 23.0.0.2 255.255.255.0
[S2]interface LoopBack2
     ip address 2.2.2.2 255.255.255.255     # 利用环回口地址建立e-trunk
[S2]ip route-static 3.3.3.3 255.255.255.255 23.0.0.3
[S2]interface Eth-Trunk1
     mode lacp-static
     security-key cipher huawei.com     # 可选配置,设置连接密钥
     timer hello 20     # 可选配置,设置Hello时间(默认10,100ms*10=1秒),这里设置是使用的默认100ms*设置的参数来定义hello时间,设置20的话也就是2秒
     timer hold-on-failure multiplier 30    # 可选配置,这个参数是告诉对端如果没有收到hello的话多少时间内处理(默认是100ms*20=20秒),这里设置30的话也就是30秒
     timer revert delay 60     # 可选配置,设置故障后的状态回切,默认是120s
     trunkport GigabitEthernet  0/0/1 to 0/0/2
[S2]e-trunk 1
     priority 1     # 设置e-trunk优先级,越小越优先
     peer-address 3.3.3.3 source-address 2.2.2.2     # 对端环回口地址和本端环回口地址建立e-trunk
[S2]interface Eth-Trunk1
     e-trunk 1     # eth-trunk加入e-trunk
S3:
[S3]sysname S3
[S3]lacp e-trunk priority 100     # 设置e-trunk的LACP优先级
[S3]lacp e-trunk system-id 0000-1111-2222     # 设置e-trunk的LACP系统ID,LACP优先级和LACP系统ID主备设备必须设置一样
[S3]interface Vlanif1
     ip address 23.0.0.3 255.255.255.0
[S3]interface LoopBack3
     ip address 3.3.3.3 255.255.255.255
[S3]ip route-static 2.2.2.2 255.255.255.255 23.0.0.2
[S3]interface Eth-Trunk1
     mode lacp-static
     security-key cipher huawei.com     # 可选配置,设置连接密钥
     trunkport GigabitEthernet  0/0/1 to 0/0/2
[S3]e-trunk 1
     priority 2     # 设置e-trunk优先级,越小越优先
     peer-address 2.2.2.2 source-address 3.3.3.3      # 对端环回口地址和本端环回口地址建立e-trunk
[S3]interface Eth-Trunk1
     e-trunk 1     # eth-trunk加入e-trunk

结果验证

华为数通 E-trunk
dis eth-trunk 1 验证结果eth-trunk接口已经Selected成功建立,四条接口的对端系统id一致,备份接口Unselect
华为数通 E-trunk
system-id是MAC地址不可修改的,优先级可以通过上图看出是1,接口状态为master
华为数通 E-trunk

测试主设备链路故障,切换备设备情况

华为数通 E-trunk
华为数通 E-trunk
causation接原因,本段成为master

作者:Zleoco,如若转载,请注明出处:https://www.zleoco.com/?p=2054

发表回复

您的电子邮箱地址不会被公开。