华为数通 OSPF综合案例

华为数通 OSPF综合案例
AR1:
[ar1]sysname ar1
[ar1]interface GigabitEthernet0/0/0
     ip address 10.1.123.1 255.255.255.0 
[ar1]ospf 1 router-id 1.1.1.1 
     area 0.0.0.0 
      network 10.1.123.0 0.0.0.255
AR2:
[ar2]sysname ar2
[ar2]interface GigabitEthernet0/0/0
     ip address 10.1.123.2 255.255.255.0 
[ar2]interface GigabitEthernet0/0/2
     ip address 10.1.24.2 255.255.255.0 
[ar2]ospf 1 router-id 2.2.2.2 
     area 0.0.0.0 
      network 10.1.123.0 0.0.0.255 
     area 0.0.0.1 
      network 10.1.24.0 0.0.0.255 
      nssa no-summary
AR3:
[ar3]sysname ar3
[ar3]interface GigabitEthernet0/0/0
     ip address 10.1.123.3 255.255.255.0 
[ar3]interface GigabitEthernet0/0/2
     ip address 10.1.35.3 255.255.255.0 
[ar3]ospf 1 router-id 3.3.3.3 
     area 0.0.0.0 
      network 10.1.123.0 0.0.0.255 
     area 0.0.0.2 
      network 10.1.35.0 0.0.0.255 
      vlink-peer 5.5.5.5
AR4:
[ar4]sysname ar4
[ar4]interface GigabitEthernet0/0/0
     ip address 10.1.24.4 255.255.255.0 
[ar4]interface LoopBack1
     ip address 10.0.0.1 255.255.255.0 
[ar4]interface LoopBack2
     ip address 11.0.0.1 255.255.255.0 
[ar4]ospf 1 router-id 4.4.4.4 
     import-route direct type 1
     area 0.0.0.1 
      network 10.1.24.0 0.0.0.255 
      nssa
AR5:
[ar5]sysname ar5

[ar5]interface GigabitEthernet0/0/0
     ip address 10.1.35.5 255.255.255.0 

[ar5]interface GigabitEthernet0/0/1
     ip address 10.1.56.5 255.255.255.0 

[ar5]ospf 1 router-id 5.5.5.5 
     area 0.0.0.2 
      network 10.1.35.0 0.0.0.255 
      vlink-peer 3.3.3.3
     area 0.0.0.3 
      authentication-mode md5 1 cipher huawei.com
      network 10.1.56.0 0.0.0.255 
AR6:
[ar6]sysname ar6
[ar6]interface GigabitEthernet0/0/0
     ip address 10.1.56.6 255.255.255.0 
[ar6]ospf 1 router-id 6.6.6.6 
     area 0.0.0.3 
      authentication-mode md5 1 cipher huawei.com
      network 10.1.56.0 0.0.0.255

结果验证

  1. 总公司与分公司A、B之间通信正常,但无法与办事处C通信。
    • 通过在区域2中建立AR3和AR5的虚连接(虚连接运行在区域0),使区域3逻辑上和区域0保持非骨干区域
  2. 分公司A的设备性能较低,希望降低路由计算、存储压力,同时考虑网络扩展,需要保留引入外部路由的功能。
    • AR4区域1修改为NSSA特殊区域,AR2区域1修改为totally NSSA特殊区域,屏蔽3、4、5类LSA,保留AR4引入外部路由的功能。
  3. 办事处C外来人员较多,采用较安全的方式保证路由交互的安全性。
    • AR5、AR6区域3开启认证,保证非认证的设备禁止接入该区域
  4. AR4引入外部路由时除了考虑外部开销之外,还需要考虑OSPF域内的开销。
    • 路由引入时,修改引入类型为type1,计算沿途路径开销

作者:Zleoco,如若转载,请注明出处:https://www.zleoco.com/?p=1955

发表回复

您的电子邮箱地址不会被公开。